The maintenance on the Multi-Factor Authentication (MFA) system is now complete. Please contact the IT Help Desk at itsupport@scasd.org if you are experiencing any issues logging in.
Thank you, IT Services
Posted Jul 02, 2025 - 10:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2025 - 09:00 EDT
Update
Dear All,
We are performing maintenance on the Multi-Factor Authentication (MFA) system on SCASD accounts. This means you might see a different screen when you are prompted for Duo. However, the steps to authenticate will remain the same.
The change will happen Wednesday, July 2nd. We’ll send more info if you need to take any action.
Contact the IT Help Desk at itsupport@scasd.org for any questions or concerns.
Thank you, IT Services
Posted Jul 01, 2025 - 13:12 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 01, 2025 - 12:08 EDT
Scheduled
Dear All,
We are performing maintenance on the Multi-Factor Authentication (MFA) system on SCASD accounts. This means you might see a different screen when you are prompted for Duo. However, the steps to authenticate will remain the same.
The change will happen Wednesday, July 2nd. We’ll send more info if you need to take any action.
Contact the IT Help Desk at itsupport@scasd.org for any questions or concerns.
Thank you, IT Services
Posted Jul 01, 2025 - 12:00 EDT
This scheduled maintenance affected: Google Services (Google Drive, Google Classroom, Gmail, Google Meet, Google Calendar) and Applications (SeeSaw, GoGuardian, MySchoolBucks, eFinancePlus, Employee Access Center (EAC), Filewave, Synergy, Slack, Plex, Other Applications, Classlink).