District Wide Network Issues

Incident Report for SCASD - IT Services

Resolved

IT Services has resolved the Wi-FI issues affecting district devices at this time.
If you are still experiencing issues please reach out to IT Services at 814-231-7743 or itsupport@scasd.org
Posted May 05, 2025 - 11:03 EDT

Monitoring

We have identified that the current connectivity issue is affecting only Apple devices.

If you are still experiencing connectivity problems, please visit your building’s IT depot or contact your building’s IT support technician for assistance.

Thank you for your patience as we work to resolve this issue.
Posted Apr 21, 2025 - 09:23 EDT

Investigating

IT Services is investigating Wi-Fi issues district-wide. Our team is actively working to resolve the problem as quickly as possible. We apologize for the inconvenience and appreciate your patience while we work through this issue.
Posted Apr 21, 2025 - 08:08 EDT
This incident affected: Network Services (Network Services (Extreme), Internet Service, Wide Area Network (WAN) Service).