Job Opening Phishing Email
Incident Report for SCASD - IT Services
Resolved
This incident has been resolved.
Posted Dec 16, 2024 - 15:44 EST
Update
We are continuing to investigate this issue.
Posted Dec 16, 2024 - 15:44 EST
Update
If any personal information such as banking information, personally identifiable information or any other important/crucial information was entered in the Job Opening Phishing Email links please contact those respective institutes to have your accounts secured/verified no instructions have taken place.

IT Services is continuing to investigate this issue and will keep you updated as progress is made.
Posted Dec 09, 2024 - 10:04 EST
Update
We are continuing to investigate this issue.
Posted Dec 09, 2024 - 09:52 EST
Update
We are continuing to investigate this issue.
Posted Dec 09, 2024 - 09:51 EST
Investigating
IT Services is aware of a phishing email titled "Job Opportunity For State College Area School District". This email is a phishing attempt to get recipients to click on it's links to obtain personal information. Please report this email as phishing within Google Mail using the orange hook located at the top-right address bar.

For additional guidance for reporting, please refer to our Knowledge Base article on how to report this email as phishing successfully: https://scasd.atlassian.net/wiki/x/JYDbIw

If you've already opened and clicked on any links in the email please change your password or call our HelpDesk for assistance immediately.

Thank you!
IT Services
Posted Dec 09, 2024 - 09:04 EST
This incident affected: Google Services (Gmail) and Applications (Other Applications).