We are now also aware that this is affecting other websites including Powerschool, Efinance, Frontline, etc.
Thank you for your patience as we work through the issues.
Posted May 14, 2025 - 12:39 EDT
Investigating
Good Afternoon,
IT Services is aware of the MAP Testing issues occurring across the district. We are working with NWEA to resolve the issues. We will keep you updated on the progress of the issue as we receive more updates from NWEA.
Thanks! IT Services
Posted May 14, 2025 - 12:33 EDT
This incident affects: District Testing Services (NWEA MAP), Network Services (Firewall, Domain Name Service (DNS)), and Applications (eFinancePlus, Other Applications).