**Tech Alert: PowerSchool Test Alerts Sent Nationwide**
Incident Report for SCASD - IT Services
Resolved
This incident has been resolved.
Posted Dec 16, 2024 - 15:38 EST
Identified
Dear State College School District Community,

We wanted to inform you of an ongoing issue with the PowerSchool application. Due to a technical glitch, test alerts intended for internal use have been inadvertently sent to all app users across the United States.

Please be assured that this is a test alert and does not reflect any actual emergency or concern within our district. Our team is in contact with PowerSchool to resolve this issue promptly.

We apologize for any confusion or inconvenience caused and appreciate your understanding. If you have any questions or concerns, please do not hesitate to reach out to our IT department.

Thank you for your attention.

Sincerely,

State College School District IT Department
Posted Nov 21, 2024 - 08:21 EST
This incident affected: Applications (Other Applications).