Crowdstrike Update

Incident Report for SCASD - IT Services

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 11:56 EDT

Investigating

Good morning,

We are rolling out an update to CrowdStrike throughout the next several days, which may trigger security alerts on your machines. These alerts are expected and do not indicate a security threat. Crowdstrike is the district's antivirus software loaded on all machines.

If you receive a notification related to CrowdStrike, no action is needed unless otherwise instructed. However, if you experience any issues, please reach out to itsupport@scasd.org
Posted May 30, 2025 - 11:37 EDT
This incident affected: Applications (Other Applications).